Note de ce sujet :
  • Moyenne : 0 (0 vote(s))
  • 1
  • 2
  • 3
  • 4
  • 5

Débutant j'ai un pb avec htpasswd
#1

Bonjour, je débute avec une raspberry pi2, je suis en train d'essayer de configurer une webcam pour la transformer en caméra IP.

J'ai trouvé un bon tuto que j'ai essayé de suivre au mieux, mais là je sèche ! Sad

Dans les explications du tuto l'auteur explique comment sécuriser la vidéo, chez moi ça ne fonctionne pas.

sudo htpasswd –c .htpasswd xxxxx
Remplacez le surligné rose par votre pseudo entré dans le fichier motion précédemment. On vous demandera ensuite le mot de passe que vous voulez mettre. Cette commande sert en faite à créer un fichier d’identifiants cryptés. Ensuite redémarrez apache2 :



Liens vers le tuto.

https://mega.co.nz/#!HQ93jYDZ!iW8atTwn7V...DkLswrSHsY

Si vous avez des idées ?

Par avance merci.
Répondre
#2

Bonjour,

As-tu bien créé le .htpasswd au bon endroit?
Pour s'en assurer, que retourne la commande
Code :
ls -la /etc/apache2

Smile

Cool
Répondre
#3

Merci,
Voici la réponse à la commande, le soucis c'est que pour le moment je n'y comprends rien Sad

[email protected] ~ $ ls -la /etc/apache2
total 80
drwxr-xr-x 7 root root 4096 févr. 20 10:54 .
drwxr-xr-x 105 root root 4096 févr. 20 14:19 ..
-rw-r--r-- 1 root root 9640 déc. 22 21:59 apache2.conf
drwxr-xr-x 2 root root 4096 févr. 20 10:54 conf.d
-rw-r--r-- 1 root root 1465 déc. 22 21:59 envvars
-rw-r--r-- 1 root root 31063 mai 25 2014 magic
drwxr-xr-x 2 root root 4096 févr. 20 10:54 mods-available
drwxr-xr-x 2 root root 4096 févr. 20 10:55 mods-enabled
-rw-r--r-- 1 root root 750 déc. 22 21:59 ports.conf
drwxr-xr-x 2 root root 4096 févr. 20 10:55 sites-available
drwxr-xr-x 2 root root 4096 févr. 20 10:57 sites-enabled
Répondre
#4

Il te manque le fichier .htpasswd. Tu as du le créer à un autre endroit lorsque tu as suivi le tuto.
Recommence en te plaçant bien dans le dossier /etc/apache2 :
Code :
cd /etc/apache2
sudo htpasswd -c .htpasswd MonLogin MonMotdePass

Cool
Répondre
#5

Contrôle si tu as bien créé le fichier
Code :
ls -la /etc/apache2
et si c'est le cas, contrôle que tu as bien défini un login
Code :
cat /etc/apache2/.htpasswd

Cool
Répondre
#6

C'est étrange, il semble que le fichier soit bien la

[email protected] /etc/apache2 $ ls -la /etc/apache2
total 80
drwxr-xr-x 7 root root 4096 févr. 20 10:54 .
drwxr-xr-x 105 root root 4096 févr. 20 14:19 ..
-rw-r--r-- 1 root root 9640 déc. 22 21:59 apache2.conf
drwxr-xr-x 2 root root 4096 févr. 20 10:54 conf.d
-rw-r--r-- 1 root root 1465 déc. 22 21:59 envvars
-rw-r--r-- 1 root root 31063 mai 25 2014 magic
drwxr-xr-x 2 root root 4096 févr. 20 10:54 mods-available
drwxr-xr-x 2 root root 4096 févr. 20 10:55 mods-enabled
-rw-r--r-- 1 root root 750 déc. 22 21:59 ports.conf
drwxr-xr-x 2 root root 4096 févr. 20 10:55 sites-available
drwxr-xr-x 2 root root 4096 févr. 20 10:57 sites-enabled
[email protected] /etc/apache2 $


Mais lorsque j'exécute la 2° commande celle ci est introuvable !

Mais je fais certainement une mauvaise interprétation de cette lecture.

cat /etc/apache2/.htpasswd

[email protected] /etc/apache2 $ cat /etc/apache2/.htpasswd
cat: /etc/apache2/.htpasswd: Aucun fichier ou dossier de ce type
[email protected] /etc/apache2 $

Merci de ta patience Gambit
Répondre
#7

Ya méprise : c'est le fichier ".htpasswd" qui manque, pas "apache.conf".
Le point devant le nom de fichier permet juste de cacher le fichier, sauf quand tu utilises la commande ls avec l'option -a. D'où ls -a.

Cool
Répondre
#8

Je veux dire qu'il faut reprendre le tuto comme indiqué dans mon post #4.

Cool
Répondre
#9

Autant pour moi :o

Pourtant il semble être là, j'ai du faire une erreur quelque part.

[email protected] /etc/apache2/sites-available $ sudo nano motion


<VirtualHost *:80>
#
ServerName ***********
#ProxyPreserveHost On
<Proxy *>
AuthType Basic
AuthName "Acces restreint"
AuthUserFile /etc/apache2/.htpasswd
Require user **********
Order deny,allow
Allow from all
</Proxy>
ProxyRequests off
ProxyPass / http://localhost:8081
ProxyPassReverse / http://localhost:8081
#
</VirtualHost>
Répondre
#10

Non, le fichier n'y est pas, ça c'est le fichier de conf du vhost. Reprends ton tuto et refait ces commandes :

gambit a écrit :Il te manque le fichier .htpasswd. Tu as du le créer à un autre endroit lorsque tu as suivi le tuto.
Recommence en te plaçant bien dans le dossier /etc/apache2 :
Code :
cd /etc/apache2
sudo htpasswd -c .htpasswd MonLogin MonMotdePass

Cool
Répondre
#11

Super Gambit, merci beaucoup, je vais pouvoir poursuivre mon installation.


[email protected] /etc/apache2 $ ls -la /etc/apache2
total 84
drwxr-xr-x 7 root root 4096 févr. 20 21:27 .
drwxr-xr-x 105 root root 4096 févr. 20 14:19 ..
-rw-r--r-- 1 root root 9640 déc. 22 21:59 apache2.conf
drwxr-xr-x 2 root root 4096 févr. 20 10:54 conf.d
-rw-r--r-- 1 root root 1465 déc. 22 21:59 envvars
-rw-r--r-- 1 root root 45 févr. 20 21:28 .htpasswd
-rw-r--r-- 1 root root 31063 mai 25 2014 magic
drwxr-xr-x 2 root root 4096 févr. 20 10:54 mods-available
drwxr-xr-x 2 root root 4096 févr. 20 10:55 mods-enabled
-rw-r--r-- 1 root root 750 déc. 22 21:59 ports.conf
drwxr-xr-x 2 root root 4096 févr. 20 10:55 sites-available
drwxr-xr-x 2 root root 4096 févr. 20 10:57 sites-enabled
[email protected] /etc/apache2 $
Répondre
#12

T'inquiète pas.; t'es pas le seul à "pédaler" avec les lignes de commandes... Bienvenu au club !
Mais je te rassure.. ça fait mal au début.... et après on commence à y prendre goût !

Lenovo Legion Y520 - Debian-10.3 Buster
FreeBox V6  -  RaspBerry Pi4-B+Raspbian Buster
Peintures, Voyages et Photos
Répondre
#13

Bonjour, petites questions, l’auteur du tuto précise « Ce qui est surligné en rouge doit être remplacé par votre adresse IP publique »
Je me suis créé une adresse sur no-ip, quelle adresse doit-elle être mise en place à la suite de ServerName ?

J’ai aussi une question sur la configuration de no-ip, que faut-il choisir dans Host Type ?

DNS Host (A) DNS Host (Round Robin) DNS Alias (CNAME)
Port 80 Redirect Web Redirect

Une petite dernière pour la route dans NAT/PAT de ma livebox, j’ai ouvert des ports (serveur web http) interne et externe en 8081, c’est correct ?
Parce que pour le moment ça ne fonctionne pas.

Merci beaucoup de vos lumières.


<VirtualHost *:80>
#
ServerName xx.xx.xx.xx:80
#ProxyPreserveHost On
<Proxy *>
AuthType Basic
AuthName "Acces restreint"
AuthUserFile /etc/apache2/.htpasswd
Require user xxxxxxxx
Order deny,allow
Allow from all
</Proxy>
ProxyRequests off
ProxyPass / http://localhost:8081
ProxyPassReverse / http://localhost:8081
#
</VirtualHost>
Ce qui est surligné en rouge doit être remplacé par votre adresse IP publique. C’est l’adresse IP de votre routeur (box). Pour la connaitre tapez sur Google « mon IP publique », vous devriez trouver des sites proposant de vous l’afficher. Et ce qui est surligné en rose doit être remplacé par votre pseudo (par exemple : toto).
Répondre
#14

Oulaya beaucoup de questions! Je vais essayer de te répondre au mieux...
Pour la directive ServerName dans ton vhost
Vu que tu héberges un seul vhost, ... pas besoin de directive ServerName. Supprime la ligne. Il y aura peut-être une correction à apporter après si un vhost par defaut est déjà existant. Mais on verra après.

De cette façon, toute requête http redirigée vers ton raspberry ira vers ce vhost. Et sera redirigé après identification vers le port local localhost:8081 permettant d'accéder à motion. (Par défaut, et pour des raisons de sécurité, motion n'écoute que sur localhost:8081.)

Cool
Répondre
#15

no-ip host type
type A pour le DNS, du coup si tu appelles ton sous-domaine monchezmoi, le FQDN de ton nom de domaine sera monchezmoi.no-ip.com.
Et tu pourras mettre cette adresse dans ton navigateur, elle sera résolue à l'adresse ip de ta box.

Petite précision, évite de publier ici ou ailleurs ton adresse ip ou ton nom de domaine no-ip. C'est pas secure.

Cool
Répondre
#16

directive nat de ton routeur (box)
Tu as ouvert le port 8081 que tu rediriges sur le port 8081 vers l'adresse locale de ton raspberry : ça marche pas. Tu dois ouvrir le port 80 et le rediriger vers le port 80 de l'adresse locale de ton raspberry.

Ce n'est pas non plus super secure. Mais on verra après.

Cool
Répondre
#17

Gambit, merci pour toutes tes précisions, j'ai enfin réussi à me connecter via internet sur ma webcam, par contre impossible de sécuriser ma vidéo par mot de passe, j'ai repris le tuto à plusieurs reprises, mais a aucun moment le site me demande un mot de passe.
Répondre
#18

Tu te connectes d'où et en entrant quoi comme adresse/port?

Cool
Répondre
#19

Depuis mon téléphone en 4G, avec mon adresse no-ip.
Répondre
#20

Commence par supprimer le nat de port sur ta box. Là tu te doutes que tu as un gros problème de sécurité.

Cool
Répondre
#21

Ceci dit, tu sais maintenant utiliser ton adresse no-ip. Dans l'immédiat, connecte toi en wifi et utilise http://iplocaledemaframboise

Cool
Répondre
#22

C'est clair, mais sans la nat plus d'accès possible !
Répondre
#23

Oui, mais tu peux toujours y accéder à partir de ton réseau local. Par exemple en wifi avec ton téléphone comme je te l'ai indiqué.
Tu résous d'abord le problème du password avant de réouvrir ta box.

Cool
Répondre
#24

Je pense qu'il te manque la directive require valid-user dans ton vhost :
Code :
<VirtualHost *:80>

# ProxyPreserveHost On
<Proxy *>
AuthType Basic
AuthName "Acces restreint"
AuthUserFile /etc/apache2/.htpasswd
Require valid-user
Order deny,allow
Allow from all
</Proxy>
ProxyRequests off
ProxyPass / http://localhost:8081
ProxyPassReverse / http://localhost:8081#
</VirtualHost>
Modifie, teste localement, et quand tout est ok, remet ta règle nat sur ta box.

Cool
Répondre
#25

J'ai vérifier et modifier le script, aucun changement, la vidéo s'affiche directement sans mot de passe.

Bigre de bougre pas si simple !
Répondre


Atteindre :


Utilisateur(s) parcourant ce sujet : 1 visiteur(s)