Note de ce sujet :
  • Moyenne : 0 (0 vote(s))
  • 1
  • 2
  • 3
  • 4
  • 5

DHCPD qui ne se lance pas...
#1

Salut à tous !
Sur mon ordinateur j'essaie d'installer un réseau WiFi avec hostapd et DHCPD, le problème c'est que DHCPD n'arrive pas à se lancer et que, donc, rien ne fonctionne Sad
Au démarrage, on me dit :
Code :
[ ok ] Starting ISC DHCP server: dhcpd[....] Starting OpenBSD Secure Shell server: sshd
[FAIL] check syslog for diagnostics. ... failed!
failed!
[FAIL] startpar: service(s) returned failure: isc-dhcp-server ... failed!
J'ai cherché beaucoup sur internet, sans aucune réponse à ce jour. Voici le contenu de divers fichiers :
/etc/network/interfaces :
Code :
auto lo

iface lo inet loopback
iface eth0 inet dhcp

#allow-hotplug wlan0
#iface wlan0 inet manual
#wpa-roam /etc/wpa_supplicant/wpa_supplicant.conf
#iface default inet dhcp

#auto br0
#iface br0 inet dhcp
#bridge_ports eth0 wlan0

iface wlan0 inet static
  address 192.168.42.1
  netmask 255.255.255.0

up iptables-restore < /etc/iptables.ipv4.nat
/etc/dhcp/dhcp.conf :
Code :
ddns-update-style none;
#
# Sample configuration file for ISC dhcpd for Debian
#
#

# The ddns-updates-style parameter controls whether or not the server will
# attempt to do a DNS update when a lease is confirmed. We default to the
# behavior of the version 2 packages ('none', since DHCP v2 didn't
# have support for DDNS.)
#ddns-update-style none;

# option definitions common to all supported networks...
#option domain-name "example.org";
#option domain-name-servers ns1.example.org, ns2.example.org;

default-lease-time 600;
max-lease-time 7200;

# If this DHCP server is the official DHCP server for the local
# network, the authoritative directive should be uncommented.
authoritative;

# Use this to send dhcp log messages to a different log file (you also
# have to hack syslog.conf to complete the redirection).
log-facility local7;

# No service will be given on this subnet, but declaring it helps the
# DHCP server to understand the network topology.

#subnet 10.152.187.0 netmask 255.255.255.0 {
#}

# This is a very basic subnet declaration.

#subnet 10.254.239.0 netmask 255.255.255.224 {
#  range 10.254.239.10 10.254.239.20;
#  option routers rtr-239-0-1.example.org, rtr-239-0-2.example.org;
#}

# This declaration allows BOOTP clients to get dynamic addresses,
# which we don't really recommend.

#subnet 10.254.239.32 netmask 255.255.255.224 {
#  range dynamic-bootp 10.254.239.40 10.254.239.60;
#  option broadcast-address 10.254.239.31;
#  option routers rtr-239-32-1.example.org;
#}

# A slightly different configuration for an internal subnet.
#subnet 10.5.5.0 netmask 255.255.255.224 {
#  range 10.5.5.26 10.5.5.30;
#  option domain-name-servers ns1.internal.example.org;
#  option domain-name "internal.example.org";
#  option routers 10.5.5.1;
#  option broadcast-address 10.5.5.31;
#  default-lease-time 600;
#  max-lease-time 7200;
#}

# Hosts which require special configuration options can be listed in
# host statements.   If no address is specified, the address will be
# allocated dynamically (if possible), but the host-specific information
# will still come from the host declaration.

#host passacaglia {
#  hardware ethernet 0:0:c0:5d:bd:95;
#  filename "vmunix.passacaglia";
#  server-name "toccata.fugue.com";
#}

# Fixed IP addresses can also be specified for hosts.   These addresses
# should not also be listed as being available for dynamic assignment.
# Hosts for which fixed IP addresses have been specified can boot using
# BOOTP or DHCP.   Hosts for which no fixed address is specified can only
# be booted with DHCP, unless there is an address range on the subnet
# to which a BOOTP client is connected which has the dynamic-bootp flag
# set.
#host fantasia {
#  hardware ethernet 08:00:07:26:c0:a5;
#  fixed-address fantasia.fugue.com;
#}

# You can declare a class of clients and then do address allocation
# based on that.   The example below shows a case where all clients
# in a certain class get addresses on the 10.17.224/24 subnet, and all
# other clients get addresses on the 10.0.29/24 subnet.

#class "foo" {
#  match if substring (option vendor-class-identifier, 0, 4) = "SUNW";
#}

#shared-network 224-29 {
#  subnet 10.17.224.0 netmask 255.255.255.0 {
#    option routers rtr-224.example.org;
#  }
#  subnet 10.0.29.0 netmask 255.255.255.0 {
#    option routers rtr-29.example.org;
#  }
#  pool {
#    allow members of "foo";
#    range 10.17.224.10 10.17.224.250;
#  }
#  pool {
#    deny members of "foo";
#    range 10.0.29.10 10.0.29.230;
#  }
#}


subnet 192.168.42.0 netmask 255.255.255.0 {
range 192.168.42.10 192.168.42.50;
option broadcast-address 192.168.42.255;
option routers 192.168.42.1;
default-lease-time 600;
max-lease-time 7200;
option domain-name "local";
option domain-name-servers 8.8.8.8, 8.8.4.4;
}
Et dans mon syslog, on me dit :
Code :
Dec  2 02:33:22 raspberrypi dhcpd: Internet Systems Consortium DHCP Server 4.2.2
Dec  2 02:33:22 raspberrypi dhcpd: Copyright 2004-2011 Internet Systems Consortium.
Dec  2 02:33:22 raspberrypi dhcpd: All rights reserved.
Dec  2 02:33:22 raspberrypi dhcpd: For info, please visit https://www.isc.org/software/dhcp/
Dec  2 02:33:22 raspberrypi dhcpd: Internet Systems Consortium DHCP Server 4.2.2
Dec  2 02:33:22 raspberrypi dhcpd: Copyright 2004-2011 Internet Systems Consortium.
Dec  2 02:33:22 raspberrypi dhcpd: All rights reserved.
Dec  2 02:33:22 raspberrypi dhcpd: For info, please visit https://www.isc.org/software/dhcp/
Dec  2 02:33:22 raspberrypi dhcpd: Wrote 0 leases to leases file.
Dec  2 02:33:24 raspberrypi dhclient: Listening on LPF/eth0/b8:27:eb:88:cc:70
Dec  2 02:33:24 raspberrypi ifplugd(eth0)[1798]: client: Listening on LPF/eth0/b8:27:eb:88:cc:70
Dec  2 02:33:24 raspberrypi dhclient: Sending on   LPF/eth0/b8:27:eb:88:cc:70
Dec  2 02:33:24 raspberrypi dhclient: Sending on   Socket/fallback
Dec  2 02:33:24 raspberrypi ifplugd(eth0)[1798]: client: Sending on   LPF/eth0/b8:27:eb:88:cc:70
Dec  2 02:33:24 raspberrypi dhclient: DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 8
Dec  2 02:33:24 raspberrypi ifplugd(eth0)[1798]: client: Sending on   Socket/fallback
Dec  2 02:33:24 raspberrypi ifplugd(eth0)[1798]: client: DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 8
Dec  2 02:33:24 raspberrypi dhclient: DHCPREQUEST on eth0 to 255.255.255.255 port 67
Dec  2 02:33:24 raspberrypi ifplugd(eth0)[1798]: client: DHCPREQUEST on eth0 to 255.255.255.255 port 67
Dec  2 02:33:24 raspberrypi dhclient: DHCPOFFER from 192.168.0.1
Dec  2 02:33:24 raspberrypi ifplugd(eth0)[1798]: client: DHCPOFFER from 192.168.0.1
Dec  2 02:33:24 raspberrypi dhclient: DHCPACK from 192.168.0.1
Dec  2 02:33:24 raspberrypi ifplugd(eth0)[1798]: client: DHCPACK from 192.168.0.1
Dec  2 02:33:25 raspberrypi dhcpd:
Dec  2 02:33:25 raspberrypi dhcpd: No subnet declaration for wlan0 (no IPv4 addresses).
Dec  2 02:33:25 raspberrypi dhcpd: ** Ignoring requests on wlan0.  If this is not what
Dec  2 02:33:25 raspberrypi dhcpd:    you want, please write a subnet declaration
Dec  2 02:33:25 raspberrypi dhcpd:    in your dhcpd.conf file for the network segment
Dec  2 02:33:25 raspberrypi dhcpd:    to which interface wlan0 is attached. **
Dec  2 02:33:25 raspberrypi dhcpd:
Dec  2 02:33:25 raspberrypi dhcpd:
Dec  2 02:33:25 raspberrypi dhcpd: Not configured to listen on any interfaces!
Quelqu'un aurait une idée ?
Merci !
Répondre
#2

Ahh quelqu'un qui fournit la conf et les logs.. cool Wink

Pouknouki a écrit :Dec 2 02:33:25 raspberrypi dhcpd: No subnet declaration for wlan0 (no IPv4 addresses).

Le 1er résultat d'un moteur de recherche sur cette ligne envoi sur:
http://raspberrypi.stackexchange.com/que...in-ap-mode

Citation :Here is a small script which solve the problem:

#!/bin/bash

/etc/init.d/hostapd restart
/sbin/ifdown wlan0
/sbin/ifup wlan0
/etc/init.d/dnsmasq restart

I'm using cronjob to run this script at the startup.

Citation :My guess would be a startup order issue. Wifi drivers can be fickle creatures. Is it possible that when dhcpd starts that wlan0 does not yet have an ip assigned, then gets one later after dhcpd has already given up?
Répondre
#3

Salut
merci de ta réponse
malheureusement ce script n'a pas l'air de fonctionner avec moi Sad
Code :
[== Indéfini ==]
sh wifi.sh
[ ok ] Stopping advanced IEEE 802.11 management: hostapd.
[ ok ] Starting advanced IEEE 802.11 management: hostapd.
/sbin/ifdown: interface wlan0 not configured
Usage: /etc/init.d/isc-dhcp-server {start|stop|restart|force-reload|status}
Failed to bring up wlan0.
sudo: /etc/init.d/dnsmasq: command not found
Répondre
#4

Salut,

Quel la référence de ta clé wifi ?
Arrive-tu à te connecter simplement sur un réseau wifi de ta box (par exemple) ?
Répondre
#5

Salut
La voilà :
http://www.adafruit.com/products/814#Technical_Details
J'ai finalement installé dnsmasq plutôt mais j'ai encore des problèmes... Sad
Répondre
#6

J'arrive peut être après la bataille ... ?

Pouknouki a écrit :malheureusement ce script n'a pas l'air de fonctionner avec moi Sad
Code :
/sbin/ifdown: interface wlan0 not configured

Et dans ton message originel :

Ton /etc/network/interfaces :
Code :
auto lo

iface lo inet loopback
iface eth0 inet dhcp

#allow-hotplug wlan0
#iface wlan0 inet manual
#wpa-roam /etc/wpa_supplicant/wpa_supplicant.conf
#iface default inet dhcp

#auto br0
#iface br0 inet dhcp
#bridge_ports eth0 wlan0

iface wlan0 inet static
  address 192.168.42.1
  netmask 255.255.255.0

up iptables-restore < /etc/iptables.ipv4.nat

Dans tes interfaces, le wlan0 est en static, c'est ton eth0 (ta prise ethernet) qui était configurée en dhcp. Donc fatalement, essayer de corriger le wlan0 (wifi) pour qu'il choppe le dhcp, ça risque de durer longtemps vu que c'est pas lui que tu as configuré en dhcp ! Smile

J'arrive peut être après la bataille, il y a si j'ai bien compris 3 topics sur ce qui me semble être la même demande ... ?
Répondre
#7

Salut !
Après la bataille... plus ou moins puisque ça ne fonctionne toujours pas.
Par contre on m'a bien dit de configurer interfaces comme ça (puisque wlan0 est en statique, on connaît l'adresse IP du routeur WiFi, par contre je dois récupérer mon adresse auprès de ma box en DHCP pour avoir internet en ethernet).
En tout cas maintenant j'utilise dnsmasq.
Répondre


Atteindre :


Utilisateur(s) parcourant ce sujet : 1 visiteur(s)