Note de ce sujet :
  • Moyenne : 0 (0 vote(s))
  • 1
  • 2
  • 3
  • 4
  • 5

Connexion impossible à mon raspberry depuis mon téléphone portable
#1

Bonjour,

Je me décide à vous contacter car j'ai cherché sur Internet une solution à mon problème sans succès.

En fait j'essaye de me connecter à mon raspberry depuis mon téléphone portable (réseau 4G) via mon IP distante mais ca ne fonctionne pas.
Je précise que j'ai bien paramétré ma Freebox (redirection des ports, etc...) et lorsque j'essaie de me connecter via Putty sur l'adresse IP distante et le port de mon raspberry ca fonctionne.
J'ai essayé via les applis Android conseillés sur le Net comme Juice SSH, ConnectBot, etc... mais à chaque fois ca ne fonctionne pas.
Par exemple sous ConnectBot je précise [email protected]:port et j'obtiens une erreur de type "Connection timed out".
J'aimerai dans la mesure du possible accéder à mon rasp en ligne de commande.

Auriez-vous une idée d'ou provient le problème ?

Merci d'avance pour votre aide !
Répondre
#2

Salut
Ton test Putty est bien fait en dehors de chez toi ? Si oui alors ça doit plus venir de la config du téléphone ou du fournisseur qui bloque le port, je sais pas si c'est possible. Mais si ça passe par putti ça ne vient pas de la config du raspberry ou de la box

Raspberry Pi Home Server : http://www.pihomeserver.fr
Hotspot Wifi avec portail captif pour Raspberry Pi: Kupiki Hotspot
Répondre
#3

Si la connexion est OK depuis ton pc sur INternet (ADSL etc.. sans 3G, 4G etc.. donc ) , il est possible (mais peu probable) que ton opérateur filtre le port 22 et/ou le SSH.
Tu peux tester de
- Ecouter sur un autre port que 22 et re-tester.
- Faire du thetering sur ton smartphone, puis de tester depuis ton PC .. qui sera donc en wifi vers ton telephone.. qui sera en 4G vers internet.. si ca marche comme ca, c'est que le pb n'est pas au niveau 4G
Répondre
#4

Merci beaucoup pour vos réponses rapides !

Grace à vos conseils je viens de me rendre compte que contrairement à ce que je pensais mon rasp n'est pas accessible depuis l'extérieur même via une connexion ssh via putty.

En fait au départ j'avais testé depuis chez moi sur mon PC via la connexion Wifi de ma Freebox d'accéder à l'IP distante de ma Box avec les ports du rasp qui vont bien et comme ca fonctionnait je pensais que le rasp était accessible depuis l'extérieur alors qu'effectivement ce n'est pas le cas.... (Shame on me.... 8.()
J'ai testé hier depuis le proxy d'un ami chez lui et ça ne fonctionne pas.

En cherchant une solution je me suis rendu compte que j'avais bien redirigé les ports depuis la Freebox OS mais pas depuis le portail free sur Internet (menu Ma Freebox->Gestion de mon routeur).
Je l'ai fait mais ça ne fonctionne toujours pas Sad
J'ai juste redirigé les ports sans toucher à la partie Baux DHCP permanents qui permet d'associer une adresse MAC à une adresse IP
Est-ce qu'il faut que j'ajoute l'adresse MAC de mon rasp aux Baux DHCP permanents ?

Sinon je précise que j'ai modifié les ports 22, 80, etc.... pour des raisons de sécurité; je les ai bien paramétrés au niveau du rasp (dans le fichier qui va bien) et au niveau du Freebox OS et du portail perso Free sur le net.
En local j'arrive à accéder à mon rasp via ces ports donc je pense qu'ils sont bien paramétrés.

Du coup je ne vois pas d'ou vient le problème, en résumé j'ai redirigé les ports aussi bien au niveau Freebox OS que sur le portail Free sur le Net, j'ai bien paramétré le port d'accès distant d'entrée depuis le Freebox OS, j'arrive à accéder au rasp en local mais pas à l'extérieur via putty ou une appli Android en précisant l'adresse IP de ma box et le port de mon rasp
Dans le Freebox OS je vois qu'il y a un bouton DHCP qui permet d'associer une adresse MAC à une adresse IP, est-ce qu'il faut que j'ajoute le MAC de mon rasp ?

Merci encore pour votre aide Wink
Répondre
#5

Moi je le fais pour que chaque machine ait la même IP à chaque fois. Au cas où ...

Raspberry Pi Home Server : http://www.pihomeserver.fr
Hotspot Wifi avec portail captif pour Raspberry Pi: Kupiki Hotspot
Répondre
#6

J'ai ajouté l'adresse MAC de mon rasp en l'associant à son IP local :
- dans la rubrique Gestion du routeur -> Baux DHCP permanents du portail Free sur le Net.
- dans la rubrique DHCP -> Baux statiques du Freebox OS.
mais ça ne fonctionne pas, je n'arrive pas à l'interroger via SSH dans Putty.
Répondre
#7

Je pense que tu as mal paramétré dans ta box.
Donne nous des screenshots en masquant l'ip publique si besoin. (mais ne sert a rien de masquer ton IP en 192.168.1.x ou équivalent)
Répondre
#8

J'ai fait des screenshots du paramétrage de ma Freebox mais je ne vois pas comment ajouter ces images (en local sur mon PC) au message ?
Je n'ai pas vu de trace d'un bouton radio au niveau de la rédaction du message pour ajouter ces images Sad
Il y a bien la possibilité d'ajouter des images via la balise image mais cela ne concerne à priori que les images contenues dans des URL.
Pourriez-vous m'aider svp ?
Répondre
#9

Tu les met sur un site hébergeur ( hostingpics par exemple ) et tu importes leurs url
Répondre
#10

Merci [email protected] pour ta réponse.

Alors voici comment j'ai paramétré ma Freebox :
  • Dans le Freebox OS


  1. Menu Configuration

    [Image: 905733FreeboxOSConfiguration.gif][/*]
  2. Menu Gestion des ports -> Redirection de ports

    [Image: 376765FreeboxOSGestiondesports.gif][/*]
  3. Menu DHCP -> Baux statiques

    [Image: 606515FreeboxOSDHCPv2.gif][/*]
  • Dans le portail Free sur Internet - Menu Gestion du routeur -> Redirection/Baux DHCP

[Image: 951277PortailFreeboxv2.gif]

J'ai uniquement flouté l'adresse MAC de mon rasp.

Pour des raisons de sécurité j'ai modifié :
- le port 22 en 23632
- le port 80 en 8396
- le port 6789 (nzbget) en 5356.

J'ai bien pensé à imputer ces modifs dans le paramétrage du rasp vu que j'arrive à y accéder en local.
Par contre je n'arrive pas à accéder à mon rasp depuis l'extérieur en SSH via Putty sur l'IP publique de ma Box et le port 23632 Sad
Répondre
#11

bah, moi, déjà, avant de tout modifier les ports, je les respecterai !
Et puis, pas de réponse au ping renforce un peu la sécurité !
Pour le port 22, c'est le ssh / 80 http / et l'autre je sais pas !
Essai d'abord avec les ports de base avant de les modifier ...
Répondre
#12

Je viens d'essayer avec les ports de base, ça ne fonctionne pas.
Le port 6789 correspond à nzbget.
Répondre
#13

freebox 5 .. il faut redemarrer il me semble !

Tu as un serveur http sur ton pi ?
Répondre
#14

C est la Freebox 6, j'ai redémarré après avoir appliqué les modifs.
Non; je n'ai pas de serveur http sur le rasp, il faut que j'en installe un ?
Répondre
#15

euh, les modif avec la 6 ne se font pas chez free, mais directement sur la freebox !!! cherche pas !

tu va au : http://192.168.0.254/login.php

et tu recommences !!!

je te fais de copies d'ecran !! ...
Répondre
#16

[Image: 703895free.jpg]


[Image: 483499free1.jpg]
Répondre
#17

Oui, j'ai déja fait ces modifs aux deux niveaux, dans le Freebox OS et chez free.
J'ai modifié le menu Gestion des ports dans le Freebox OS :

[Image: 746892376765FreeboxOSGestiondesports.gif]

et j'ai modifié le menu DHCP dans le Freebox OS

[Image: 791992606515FreeboxOSDHCPv2.gif]

Est-ce qu'ils sont bien paramétrés ?
Répondre
#18

je ne sais pas , je ne pense pas que tes ports exotiques soient bon pour ton application extérieur ...
Répondre
#19

La conf coté freebox semble ok.

- Dans la conf de la V6, dans "Mode Reseau" tu es bien en "routeur" ?


- Que donne depuis un PC sur Internet la commande (qui ne marche pas):

ssh -p 23632 -v [email protected]

Remplace tonLogin et tonIPPublique (et si j'ai bien suivi le port SSH est le 23632)


- Que donne depuis un PC sur ton réseau local la commande (qui marche):

ssh -p 23632 -v [email protected]

Remplace tonLogin et tonIPPrivee (et si j'ai bien suivi le port SSH de ton Rasp est le 23632)
Répondre
#20

essaie par là : http://www.canyouseeme.org/
si tes ports sont bien ouverts

et je suppose que tu as bien déclaré au pi dans /etc/ssh/sshd_config ton changement de port !

# What ports, IPs and protocols we listen for
Port 22


puis utiliser ssh -p a la place de ssh tout court !
Répondre
#21

Merci à vous deux pour votre aide !

[email protected] a écrit :je ne sais pas , je ne pense pas que tes ports exotiques soient bon pour ton application extérieur ...

J'ai modifié les ports pour revenir à la situation classique avec les ports habituels 22, 80, etc....
Tu as raison, on va déjà tester si ça marche avec ces ports la avant de les changer.

Uggy a écrit :- Dans la conf de la V6, dans "Mode Reseau" tu es bien en "routeur" ?

Oui je viens de vérifier, je suis bien en mode routeur

Uggy a écrit :- Que donne depuis un PC sur Internet la commande (qui ne marche pas):
ssh -p 23632 -v [email protected]
Remplace tonLogin et tonIPPublique (et si j'ai bien suivi le port SSH est le 23632)

Je n'arrive pas à me connecter via putty sur mon rasp à un PC depuis Internet.
Est-ce que tu souhaites que je lance cette commande depuis mon réseau local ?

Uggy a écrit :- Que donne depuis un PC sur ton réseau local la commande (qui marche):
ssh -p 23632 -v [email protected]
Remplace tonLogin et tonIPPrivee (et si j'ai bien suivi le port SSH de ton Rasp est le 23632)

Code :
[== Indéfini ==]
[email protected] ~ $ ssh -p 22 -v [email protected]
OpenSSH_6.0p1 Debian-4+deb7u2, OpenSSL 1.0.1e 11 Feb 2013
debug1: Reading configuration data /etc/ssh/ssh_config
debug1: /etc/ssh/ssh_config line 19: Applying options for *
debug1: Connecting to 192.168.0.43 [192.168.0.43] port 22.
debug1: Connection established.
debug1: SELinux support disabled
debug1: identity file /home/pi/.ssh/id_rsa type -1
debug1: identity file /home/pi/.ssh/id_rsa-cert type -1
debug1: identity file /home/pi/.ssh/id_dsa type -1
debug1: identity file /home/pi/.ssh/id_dsa-cert type -1
debug1: identity file /home/pi/.ssh/id_ecdsa type -1
debug1: identity file /home/pi/.ssh/id_ecdsa-cert type -1
debug1: Remote protocol version 2.0, remote software version OpenSSH_6.0p1 Debian-4+deb7u2
debug1: match: OpenSSH_6.0p1 Debian-4+deb7u2 pat OpenSSH*
debug1: Enabling compatibility mode for protocol 2.0
debug1: Local version string SSH-2.0-OpenSSH_6.0p1 Debian-4+deb7u2
debug1: SSH2_MSG_KEXINIT sent
debug1: SSH2_MSG_KEXINIT received
debug1: kex: server->client aes128-ctr hmac-md5 none
debug1: kex: client->server aes128-ctr hmac-md5 none
debug1: sending SSH2_MSG_KEX_ECDH_INIT
debug1: expecting SSH2_MSG_KEX_ECDH_REPLY
debug1: Server host key: ECDSA xxx
The authenticity of host '192.168.0.43 (192.168.0.43)' can't be established.
ECDSA key fingerprint is xxx.
Are you sure you want to continue connecting (yes/no)? yes
Warning: Permanently added '192.168.0.43' (ECDSA) to the list of known hosts.
debug1: ssh_ecdsa_verify: signature correct
debug1: SSH2_MSG_NEWKEYS sent
debug1: expecting SSH2_MSG_NEWKEYS
debug1: SSH2_MSG_NEWKEYS received
debug1: Roaming not allowed by server
debug1: SSH2_MSG_SERVICE_REQUEST sent
debug1: SSH2_MSG_SERVICE_ACCEPT received
debug1: Authentications that can continue: publickey,password
debug1: Next authentication method: publickey
debug1: Trying private key: /home/pi/.ssh/id_rsa
debug1: Trying private key: /home/pi/.ssh/id_dsa
debug1: Trying private key: /home/pi/.ssh/id_ecdsa
debug1: Next authentication method: password
[email protected]'s password:
debug1: Authentication succeeded (password).
Authenticated to 192.168.0.43 ([192.168.0.43]:22).
debug1: channel 0: new [client-session]
debug1: Requesting [email protected]
debug1: Entering interactive session.
debug1: Sending environment.
debug1: Sending env LANG = fr_FR.UTF-8
Linux raspcoyote 3.18.11+ #781 PREEMPT Tue Apr 21 18:02:18 BST 2015 armv6l

The programs included with the Debian GNU/Linux system are free software;
the exact distribution terms for each program are described in the
individual files in /usr/share/doc/*/copyright.

Debian GNU/Linux comes with ABSOLUTELY NO WARRANTY, to the extent
permitted by applicable law.
Last login: Sun Aug 16 23:50:55 2015 from freebox-server.local

Je ne m'y connais pas beaucoup en réseau mais je me suis dit que c'était mieux pour des raisons de sécurité de ne pas divulger ma clé ECDSA (que j'ai remplacé par xxx), je ne sais pas si j'ai eu raison ?
Sinon à la première exécution il ne connaissait pas mon rasp (192.168.0.43) mais lors de la deuxième exécution de la commande ssh, j'ai eu un message du type "Host '192.168.0.43' is known and matches the ECDSA host key."

[email protected] a écrit :essaie par là : http://www.canyouseeme.org/
si tes ports sont bien ouverts

mes ports ne sont pas ouverts....

[email protected] a écrit :et je suppose que tu as bien déclaré au pi dans /etc/ssh/sshd_config ton changement de port !

Oui j'ai bien déclaré mon changement de port (22 devient 23632).
Depuis j'ai remis 22 pour qu'on teste depuis une situation classique.

[email protected] a écrit :puis utiliser ssh -p a la place de ssh tout court !

J'ai bien lancé les commandes ssh de Uggy avec l'argument "-p"
Répondre
#22

Coyote a écrit :
[email protected] a écrit :essaie par là : http://www.canyouseeme.org/
si tes ports sont bien ouverts

mes ports ne sont pas ouverts....
Répondre
#23

je viens d'essayer avec tes ports exotiques ... resultat niet !

[Image: 201791free3.jpg]
Répondre
#24

[email protected] a écrit :je viens d'essayer avec tes ports exotiques ... resultat niet !

Comme précisé plus haut j'ai remis les ports initiaux à savoir 22, 80, etc....
Répondre
#25

Coyote a écrit :Est-ce que tu souhaites que je lance cette commande depuis mon réseau local ?

Oui. C'était bien la question suivante.
Par contre, ton test "[email protected] ~ $ ssh -p 22 -v [email protected]" c'est depuis le Rasp lui même, vaudrait mieux depuis une autre machine du LAN


Mais a priori, tout semblerait OK..
Etrange, car c'est pas compliqué et ca fonctionne très bien en théorie.. on va finir par trouver.
Répondre


Atteindre :


Utilisateur(s) parcourant ce sujet : 1 visiteur(s)