Sujet fermé
Note de ce sujet :
  • Moyenne : 0 (0 vote(s))
  • 1
  • 2
  • 3
  • 4
  • 5

Connexion RJ45
#1

Bonjour,
Je n'arrive pas à me connecter avec mon rj45. Les les du raspberry s'allument bien mais je n'ais pas internet.
Ifconfig donne UP broadcast running multicast
Que dois je faire ???
Merci d'avance

Débutant en informatique, et avec linux, je suis devenu fan du raspberry pi depuis quelques années déjà !! Smile
#2

Regarde sur la ligne juste au dessus (inet adr: ), ou bien sur ta box tu doit pouvoir voir toutes les adresses IP alloués
#3

Je n'ait pas de inet adresse, il y a juste mtu :1500 metric :1 RX Packers:1088 errors:0
Pouvez m'indiquez ce que cela signifie.
Cordialement

Débutant en informatique, et avec linux, je suis devenu fan du raspberry pi depuis quelques années déjà !! Smile
#4

Peux tu faire la commande ifconfig dans un terminal et nous envoyer une photo de l'écran ? ce sera plus claire.
#5

Cela donne ça. je n'ait pas pu faire de copie d'écran, car je ne savais pas comment faire sans "scrot" que je n'ait pas. peut-être le savez-vous ?

eth0 Link encap:Ethernet HWaddr b8:27:eb:1f:f3:4d
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:9 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 lg file transmission:1000
RX bytes:612 (612.0 B) TX bytes:0 (0.0 B)
[email protected] ~ $

Merci pour votre aide

Débutant en informatique, et avec linux, je suis devenu fan du raspberry pi depuis quelques années déjà !! Smile
#6

Que donne aussi

Code :
[== Indéfini ==]
cat /etc/network/interfaces && sudo /etc/init.d/networking restart && ifconfig -a
#7

Aurais je fais une erreur dans mon fichier interfaces ??
Je l'avait en effet configuré pour une clé wifi.

Débutant en informatique, et avec linux, je suis devenu fan du raspberry pi depuis quelques années déjà !! Smile
#8

Bonsoir.

Ce qui est curieux, c'est qu'aucune adresse IP n'apparaisse...
Es-tu en DHCP ? en fixe ?

Dans ton fichier /etc/network/interfaces, tu devrais avoir quelque chose de ce style :

Code :
[== Indéfini ==]
auto lo
iface lo inet loopback
iface eth0 inet dhcp

OU si tu es en fixe (c'est un exemple d'adressage, je ne sais pas comment tu es chez toi)

Code :
[== Indéfini ==]
auto lo
iface lo inet loopback
iface eth0 inet static
        address 192.168.XXX.YYY
        netmask 255.255.255.0
        gateway 192.168.XXX.YYY
        broadcast 192.168.XXX.255
#9

pi35 a écrit :Aurais je fais une erreur dans mon fichier interfaces ??
Je l'avait en effet configuré pour une clé wifi.

La RJ45 a des chances de s'appeler eth0
La clé Wifi a des chances de s'appeler wlan0
...
#10

Mon fichier me donne :
#allow-hotplug wlan0
#iface wlan0 inet manual
# iface défaut inet DHCP

Allow-hotplug wlan0
Iface wlan0 inet DHCP
Wpa-ssid "ssid1"
Wpa-psk "mdp1"

Ainsi, il semblerais que je sois connecté en wifi, cependant ma clé TP link WN722N n'a jamais marché, et je veut maintenant être connecté en rj45. Que dois-je faire ???
Peut-être savez-vous même comment passer en connection wifi facilement avec ma clé :-)

Débutant en informatique, et avec linux, je suis devenu fan du raspberry pi depuis quelques années déjà !! Smile
#11

Remet ce qu'il y a par defaut.. je crois:

Code :
[== Indéfini ==]
auto eth0
iface eth0 inet dhcp
#12

D'accord avec Uggy
Et éventuellement redémarrer le service réseau pour une prise en compte des modifications si aucun redémarrage de la machine n'est prévu Wink

Code :
[== Indéfini ==]
sudo service networking restart
#13

Je vais essayer, merci Smile

Débutant en informatique, et avec linux, je suis devenu fan du raspberry pi depuis quelques années déjà !! Smile
#14

Bonjour,
J'ai remplacé le fichier network/interfaces par :
Code :
[== Indéfini ==]
auto lo

iface lo inet loopback
iface eth0 inet dhcp

allow-hotplug wlan0
iface wlan0 inet manual
wpa-roam /etc/wpa_supplicant/wpa_supplicant.conf
iface default inet dhcp

Cependant, cela ne marche toujours pas et je n'arrive pas à avoir le réseau. Je suis complètement désespéré.

Débutant en informatique, et avec linux, je suis devenu fan du raspberry pi depuis quelques années déjà !! Smile
#15

ça ne marche pas sur ton cable RJ45 ? tu as enlevé la clès WIFI ? ton fichier est bon, es tu sur que ton DHCP est ok ?
#16

Je suis bien connecté avec le rj45, mais que veut tu dire par mon DHCP est bon ???

Débutant en informatique, et avec linux, je suis devenu fan du raspberry pi depuis quelques années déjà !! Smile
#17

ton DHCP est il up ? accepte t'il les connexions sans filtre d'adresse mac ... (c'est quoi une box, un vrai serveur ? )
#18

Je ne sais pas vraiment. J'ai une box free et je crois que les paramètres sont bons car j'ai déjà réussi à avoir le réseau sur mon raspberry mais entre temps, j'ai modifié tous les réglages pour passer en wifi. C'est à partir de ce moment que je ne parvient plus à récupérer le réseau avec un rj45

Débutant en informatique, et avec linux, je suis devenu fan du raspberry pi depuis quelques années déjà !! Smile
#19

Bien, je te propose de tous reprendre depuis le début.
Si j'ai les bonnes hypothèses, tu souhaites connecter ton raspberry en RJ45 en passant par ta free box qui fait serveur DHCP.
La config a fonctionné au moins une fois (c'est à dire que tu as réussi à accéder à internet ou à pinger un autre ordinateur local).

Comme cela a fonctionné une 1ere fois, je suppose que le pbs ne vient pas du DHCP (de plus tu n'y pas touché à priori).

1ère chose quand tu modifies un fichier système essaye d'avoir une traçabilité avec des commentaires en précisant les dates de changement ou de sauvegarder les différentes versions.

Comme tu ne souhaites plus le wifi je te propose d'alléger ton fichier interfaces comme suis :

Code :
[== Indéfini ==]
#configuration de l'interface loopback
#démarrage de l'interface à chaque reboot
auto lo
#configuration en mode loopback
iface lo inet loopback

#démarrage de l'interface à chaque reboot
#ajout 2014 03 13
auto eth0
#configuration en mode adresse dynamique DCHP
iface eth0 inet dhcp

#plus de wifi
#suppression 2014 03 13
#allow-hotplug wlan0
#iface wlan0 inet manual
#wpa-roam /etc/wpa_supplicant/wpa_supplicant.conf

iface default inet dhcp

Une fois que nous avons fait cela, nous redemarrons le service reseaux :
Code :
[== Indéfini ==]
sudo service networking restart

le service doit redémarer sans erreur visible à l'écran (si tu as des messages bizzares tu me les envoies).

on vérfie que le service est up au cas où :
Code :
[== Indéfini ==]
service networking status
Ca renvoie :
Code :
[== Indéfini ==]
networking start/running
Maintemant je contrôle :
Code :
[== Indéfini ==]
ifconfig
voici ce que j'ai chez moi :
Code :
[== Indéfini ==]
eth0      Link encap:Ethernet  HWaddr 54:04:a6:95:84:98
          inet adr:192.168.1.28  Bcast:192.168.1.255  Masque:255.255.255.0
          adr inet6: fe80::5604:a6ff:fe95:8498/64 Scope:Lien
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          Packets reçus:26212913 erreurs:0 :0 overruns:0 frame:0
          TX packets:15227886 errors:0 dropped:0 overruns:0 carrier:6
          collisions:0 lg file transmission:1000
          Octets reçus:38566406482 (38.5 GB) Octets transmis:2348841850 (2.3 GB)

lo        Link encap:Boucle locale
          inet adr:127.0.0.1  Masque:255.0.0.0
          adr inet6: ::1/128 Scope:Hôte
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          Packets reçus:1935 erreurs:0 :0 overruns:0 frame:0
          TX packets:1935 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:0
          Octets reçus:120884 (120.8 KB) Octets transmis:120884 (120.8 KB)
on voit bien que la ligne inet adr a reçu une Ip.

Peux tu essayer ces manip après avoir rebooter ton raspi, chez moi elles ont fonctionnées en partant d'un raspi fonctionnant à partir d'une clès wifi que j'ai passé pour l'occasion en RJ45.
Si cela ne fonctionne pas tu me renvoies les messages de commande à chaques étapes.

Courrage la 1ère c'est tjs complexe :-) sinon ce ne serait pas drôle
#20

Merci beaucoup pour ton aide, je vais essayer ça.

Débutant en informatique, et avec linux, je suis devenu fan du raspberry pi depuis quelques années déjà !! Smile
#21

J'ai testé et ça marche parfaitement, merci beaucoup pour ton aide :-)

Débutant en informatique, et avec linux, je suis devenu fan du raspberry pi depuis quelques années déjà !! Smile
#22

Si tu dois connecter du wifi, je te donnerais la manip.
#23

Cependant, ifconfig détecte certaines erreurs. En voici une copie :
Code :
[== Indéfini ==]
eth0      Link encap:Ethernet  HWaddr b8:27:eb:1f:f3:4d  
          inet adr:192.168.0.17  Bcast:192.168.0.255  Masque:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:4410 errors:0 dropped:0 overruns:0 frame:0
          TX packets:3218 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:1000
          RX bytes:4997457 (4.7 MiB)  TX bytes:411590 (401.9 KiB)

lo        Link encap:Boucle locale  
          inet adr:127.0.0.1  Masque:255.0.0.0
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:8 errors:0 dropped:0 overruns:0 frame:0
          TX packets:8 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:0
          RX bytes:1104 (1.0 KiB)  TX bytes:1104 (1.0 KiB)

Débutant en informatique, et avec linux, je suis devenu fan du raspberry pi depuis quelques années déjà !! Smile
#24

Remarque je voudrais bien la manip pour le wifi aussi car je n'ai jamais reussi non plus. J'ai en effet une clé wifi tp link wn722n et je n'arrive pas à récupérer les drivers nécessaires à la configuration du pilote.

Débutant en informatique, et avec linux, je suis devenu fan du raspberry pi depuis quelques années déjà !! Smile
#25

Du vois où des erreur ?
Tu deux interfaces une de loopback (lo) et ton RJ45 (eth0). Je ne vois rien de problèmatique dans ta copie d'écran.
Sujet fermé


Atteindre :


Utilisateur(s) parcourant ce sujet : 1 visiteur(s)