En raison de spams récurrents, les messages des nouveaux inscrits sont modérés a priori. Ne vous inquiétez pas si vous ne voyez pas apparaitre votre message immédiatement sur le forum. (November 04, 2021) x

Note de ce sujet :
  • Moyenne : 0 (0 vote(s))
  • 1
  • 2
  • 3
  • 4
  • 5

Association perenne entre wlanX et adresse Mac
#1

Bonjour,

J'ai deux réseaux wifi (sur deux routeurs différents), appelons les MonReseau1 et MonReseau2.
J'ai également un raspi4 (mais pas que, il a des petits frères) équipé avec une clé wifi usb, en plus de la connexion filaire et de la puce wifi intégrée, avec un OS Buster mis à jour régulièrement.
Le Raspi accède à deux interfaces wifi ''wlan0'' et ''wlan1'' (et à eth0, par commande ip ou ifconfig).
Le fichier ''etc/dhcpcd.conf'' me définit les liens entre les interfaces logiques et les adresses IP des réseaux.
Au départ de mes essais, les adresses locales du raspi étaient dynamiques. Le raspi devant servir de serveur, j'ai essayé de les mettre en statique, chaque wlan sur un réseau wifi.

Le problème :
Par une ''logique'' (je ne crois pas au hasard dans ce domaine technique), je voudrais comprendre : en adresse dynamique, le wlan0 est associé tantôt à MonReseau1, tantôt à MonReseau2, et même comportement pour wlan1. En adresse statique, même comportement instable dans les liaisons entre interface logique et réseau physique. Pourquoi ? J'ai lu quelque part que cette liaison peut dépendre de la qualité du réseau ''radio'' entre le routeur et l'équipement, qualité totalement incontrôlable a priori.
J'ai essayé de qualifier l'attribution des liens par un  ''priority = 1 ou 100'' dans le etc/../wpa_supplicant.conf mais avec peu d'effet.

La question :
Existe-t-il, je pense dans Dhcpcd.conf mais peut-être ailleurs, le moyen (une commande particulière  ou une option) pour associer de façon certaine l'adresse mac de la puce wifi (que ce soit la puce intégrée dans le raspi ou la puce dans la cle usb) à une interface choisie (wlan0 ou wlan1) et que cette interface soit liée à un reseau wifi pour que le pi accède à chaque réseau de façon stable et prévue ?
A priori, dans Buster, l'usage de ''etc/../interfaces.conf'' est abandonné.
Je voudrais éviter le passage par un paramétrage dans les routeurs wifi des adresses mac acceptables ou non (liste blanche ou noire > le pi ou la clé peut devoir être remplacé) et avoir quelque chose qui soit facilement accessible par script au démarrage du raspi.
Si on peut éviter du VPN ou autre applicatif, ce serait bien.

La finalité de tout cela est d'avoir un réseau de Pi qui causent entre eux via wifi (sur leur carte intégrée), qui ne soient pas accessibles de l'extérieur mais qui remontent leurs informations au raspi équipé des deux interfaces wifi, lequel pourrait accéder à la toile via la box du FAI. Grosso modo, c'est ce qu'on fait sur un switch filaire qui a la capacité d'isoler deux réseaux RJ45.
Dans tous les essais que j'ai pu mener, il n'y a aucun problème de connexion à proprement parler (ssid, cle wpa, ...). Tout cela est réglé.
La seule question est l'aléa du réseau vers lequel le wifi veut bien transiter.
Merci à Tous.
Répondre
#2

Bonjour,

sous PI OS le paramétrage du réseau utilise networking.service et dhcpcd.service, la sécurité WiFi est confiée à wpa-supplicant.

Comme seules les interfaces  WiFi nous intéressent ici, je pense qu'il faudrait :
1) s'assurer que les 2 interfaces disposent chacune d'un nom unique
2) modifier le paramétrage de wpa-supplicant
3) adapter le paramétrage du démon dhcpcd

1 -> Utiliser udev pour fixer le nom d'une interface réseau :
  sudo nano /etc/systemd/network/11-wifi1.link
      [Match]
      MACAddress=xx:xx:xx:xx:xx:xx

      [Link]
      Name=wifi1
Après reboot, l'interface WiFi ayant cette MACAddress s'appellera wifi1.
Faire l'équivalent pour wifi2 en créant /etc/systemd/network/12-wifi2.link
(les numéros en début du nom des fichiers obéissent à certains critères).

2 -> C'est wpa-supplicant qui est chargé de la connexion sécurisée d'une interface WiFi.
Créer un service paramétré pour wifi1 :
  sudo nano /etc/wpa_supplicant-wifi1.conf
      ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
      update_config=1
Après sauvegarde ajouter (en les adaptant) les paramètres de connexion sur le premier AP:
  sudo wpa_passphrase "SSID_AP1" "PASSWORD_AP1" >> /etc/wpa_supplicant-wifi1.conf
Faire l'équivalent pour wifi2.
Automatiser le chargement des 2 nouveaux services au boot :
  sudo systemctl enable [email protected]
  sudo systemctl enable [email protected]
Désactiver l'ancien paramétrage sans le supprimer :
  sudo systemctl disable wpa_supplicant

3 -> Paramétrer dhcpcd :
  sudo nano /etc/dhcpcd.conf
      interface wifi1

      interface wifi2
        static ip_address=192.168.1.240/24
        static domain_name_servers=9.9.9.9 192.168.1.1
        static routers=192.168.1.1
(dans mon exemple, wifi1 utilise DHCP alors que wifi2 utilise un adressage statique)

4 -> Redémarrer le raspi et ça devrait être OK
Répondre


Atteindre :


Utilisateur(s) parcourant ce sujet : 1 visiteur(s)