RaspFR :: Forum

Forum de la communauté francophone de Raspberry PI.

Vous n'êtes pas identifié(e).

Annonce

Canal irc: #raspfr sur zeolia.net

#1 03-05-2017 09:37:47

aguirab
Membre
Lieu : NICE
Inscription : 26-03-2016
Messages : 131

ne boote pas GUI -- résolu --

bonjour,
après avoir changé le nom d'utilisateur sur mon RPi2 wheezy
il ne boote plus directement sur le GUI
un écran blanc s'affiche et demande login et mot de passe
pour afficher l'écran (la framboise)
----
et aussi, la première fois que je fais sudo il me demande le mot de passe
ensuite il ne demande plus

un (ou plusieurs) fichier de configuration ne doit pas être à jour
lequel ?

Dernière modification par aguirab (03-05-2017 22:24:34)

Hors ligne

#2 03-05-2017 09:49:46

CrazyCat
Chat
Inscription : 14-01-2016
Messages : 429

Re : ne boote pas GUI -- résolu --

Ca se fait directement par raspi-config:

3 Boot option
B1 Desktop / CLI
B3 Desktop (ou B4 Desktop autologin)

Je te conseille (à la dernière étape) l'option B3 sans quoi tu seras toujours connecté avec l'utilisateur pi

Concernant le sudo, c'est tout à fait normal. Tu peux modifier ça avec visudo en mettant une ligne (ou éditant s'il y a déjà une entrée avec ton utilisateur):

tonuser ALL=(ALL) NOPASSWD: ALL

Il faut bien entendu remplacer "tonuser" par le nom de ton utilisateur qui fait le sudo.

Hors ligne

#3 03-05-2017 22:22:22

aguirab
Membre
Lieu : NICE
Inscription : 26-03-2016
Messages : 131

Re : ne boote pas GUI -- résolu --

bonjour,
en cherchant sur le forum raspberrypi.stackexchange.com j'ai trouvé une solution :

I used the raspi-config to enable automatically booting to the desktop with the PI user, then from terminal type: sudo nano /etc/lightdm/lightdm.conf find the line for autologin-user=pi and change pi to the desired username. ctrl+x to exit, Y to save. reboot the pi. (sudo shutdown -r now) and it should boot into the desired user.

pour le sudo sans mdp j'ai appliqué ta méthode
mofidié - en faisant sudo visudo -
la ligne

 pi ALL=(ALL) NOPASSWD:ALL 

en remplaçant pi par mon $USER

(je n'ai pas de doc sur la commande visudo j'ai fait sudo visudo au hasard)
ça marche
merci

Hors ligne

#4 04-05-2017 11:09:58

CrazyCat
Chat
Inscription : 14-01-2016
Messages : 429

Re : ne boote pas GUI -- résolu --

visudo n'est qu'un éditeur texte (basé sur vi) qui est le seul moyen d'éditer le fichier sudoers. Pour plus d'informations: http://www.informatix.fr/tutoriels/unix … -visudo-81

Hors ligne

#5 04-05-2017 22:55:39

aguirab
Membre
Lieu : NICE
Inscription : 26-03-2016
Messages : 131

Re : ne boote pas GUI -- résolu --

bonjour,
ok merci pour ta réponse précise
éditeur vi + sudo
pour le fichier sudoers

Dernière modification par aguirab (04-05-2017 22:56:19)

Hors ligne

Pied de page des forums