RaspFR :: Forum

Forum de la communauté francophone de Raspberry PI.

Vous n'êtes pas identifié(e).

Annonce

Canal irc: #raspfr sur zeolia.net

#1 26-05-2017 12:47:53

Squale76
Membre
Inscription : 26-05-2017
Messages : 4

RPi3 - GPIO - 2N7000 - Problème pour monter relais

Bonjour à tous,

J'essaie depuis des jours de faire basculer un relais 5V de ce type (XCSOURCE 5PCS 5V 1 Canal Relais Module Bouclier Optocoupleur) par un GPIO de mon RPi v3.
Voici mon branchement :
337930DomoticBranchementbb.png

L'alimentation est en réalité une alimentation de PC qui alimente en 5v.

Mes Tests :

  • Passage en mode OUT du GPIO 16

    • Passage à HIGH du GPIO 16

      • Sur la Gate (borne centrale du 2N7000), j'ai bien ~3,2v mais sur le Drain, j'ai 0v.

    • Passage à LOW du GPIO 16

      • Sur la Gate (borne centrale du 2N7000), j'ai bien ~0,008v et toujours 0v sur le Drain.

  • Ajout d'une résistance entre Masse et Borne du GPIO 16

    • Passage à HIGH du GPIO 16

      • Sur la Gate (borne centrale du 2N7000), j'ai bien ~3,2v mais sur le Drain, j'ai 0v.

    • Passage à LOW du GPIO 16

      • Sur la Gate (borne centrale du 2N7000), j'ai bien ~0,008v et toujours 0v sur le Drain.

Je sèche... Merci d'avance pour votre aide

Hors ligne

#3 26-05-2017 21:24:19

Squale76
Membre
Inscription : 26-05-2017
Messages : 4

Re : RPi3 - GPIO - 2N7000 - Problème pour monter relais

Comment savoir s'il est polarisé ?
Je mesure les tensions avec un multimètre, je ne suis pas équipé de matériel plus sophistiqué.

Hors ligne

#5 27-05-2017 11:52:13

montotof123
Membre
Inscription : 01-03-2017
Messages : 7

Re : RPi3 - GPIO - 2N7000 - Problème pour monter relais

Bonjour,

Je ne vois absolument pas pourquoi tu t’embêtes avec un transistor.
Le module "XCSOURCE 5PCS 5V 1 Canal Relais Module Bouclier Optocoupleur" comporte un optocoupleur pour protéger le GPIO du Raspberry.
Tu peux directement câbler la broche IN du module sur la GPIO

Pour info, en bas de la page Amazon, il est écrit

Spécifications:

Version de tension: 5V
Le courant statique: 4mA
Courant de fonctionnement: 65mA
Tension de déclenchement: 2-5V
Courant de déclenchement: 2mA

Donc le module déclenche sans problème à 3.3V et une GPIO peux fournir 2mA sans soucis.

Bonne journée

Hors ligne

#6 28-05-2017 14:55:36

Squale76
Membre
Inscription : 26-05-2017
Messages : 4

Re : RPi3 - GPIO - 2N7000 - Problème pour monter relais

Bonjour,

Test effectué en branchant directement le GPIO su le IN du relais et impossible de changer l'état du relais, quel que soit l'état du GPIO.
Le relais change d'état uniquement lorsque je débranche le IN du GPIO.

Pour info, en position HIGH du GPIO, j'ai 3.30v entre GPIO et GND et 0.18v en position LOW du GPIO. Si ça peut aider ...

Dernière modification par Squale76 (28-05-2017 14:59:09)

Hors ligne

#7 28-05-2017 21:21:27

Squale76
Membre
Inscription : 26-05-2017
Messages : 4

Re : RPi3 - GPIO - 2N7000 - Problème pour monter relais

Après des tests sur une breadboard sans soudure, le montage fonctionne donc bilan.... mauvaise soudure. J'ai plus qu'à reprendre le poste à souder et refaire l'ensemble de mes soudures... big_smile

Merci pour votre aide.

Hors ligne

Pied de page des forums