RaspFR :: Forum

Forum de la communauté francophone de Raspberry PI.

Vous n'êtes pas identifié(e).

Annonce

Canal irc: #raspfr sur zeolia.net

#1 13-02-2017 14:24:38

czeuw
Membre
Inscription : 13-02-2017
Messages : 4

Erreur 403 serveur

Hello,

J'ai installé LAMP sur mon Raspberry. Coté serveur, tout a l'air de fonctionner sauf une chose.

J'accède sans problème à mon serveur via http://localhost
J'accède sans problème à mon serveur au départ d'un ip externe.

Le problème est que lorsque je me connecte d'un appareil provenant de mon reseau local vers l'ip externe de mon
réseau (une DMZ a été mise en place pour pointer vers le Raspberry), j'obtient un code 403 Forbidden.

Je me suis demandé d'où cela pouvait provenir. De ma box (bbox2)? Bizarre car elle accepte les requetes de l'extérieur...
ou bien de ma configuration apache?

Bref j'ai bien parcouru les forums mais n'ai toujours pas de solution à mon problème. Quelqu'un peut m'aider ?


Merci !

Hors ligne

#2 13-02-2017 15:00:37

CrazyCat
Chat
Inscription : 14-01-2016
Messages : 420

Re : Erreur 403 serveur

Il faudrait savoir qui te renvoie l'erreur 403, regarde dans le log d'erreur d'apache si tu vois tes tentatives de connexion.
Mais j'ai eu un souci de ce genre avec une box qui refusait qu'on l'appelle l'appelle par son IP externe en étant sur le réseau local, ça doit provoquer des soucis de routage.

Hors ligne

#3 13-02-2017 15:04:41

czeuw
Membre
Inscription : 13-02-2017
Messages : 4

Re : Erreur 403 serveur

Hello,

Pas de problème visiblement, c'est tout ce que ca m'affiche:

[Mon Feb 13 06:25:05.565596 2017] [mpm_prefork:notice] [pid 5254] AH00163: Apache/2.4.10 (Raspbian) configured -- resuming normal operations
[Mon Feb 13 06:25:05.565726 2017] [core:notice] [pid 5254] AH00094: Command line: '/usr/sbin/apache2'


Je ne suis pas un expert mais je penche aussi pour un souci au niveau de la box.

Hors ligne

#4 13-02-2017 15:40:53

czeuw
Membre
Inscription : 13-02-2017
Messages : 4

Re : Erreur 403 serveur

Visiblement ca vient de ma box qui détecte une rebinding attack.

Feb 13 14:30:35 2017    System Log    Message    daemon.info wbm_run: request received with source IP 0xc0a80104 and destination IP 0xc0a80101

[repeated 4 times, last time on Feb 13 14:30:51 2017]
Feb 13 14:30:11 2017    System Log    Message    daemon.warn CGI /home/httpd/html/index.cgi returned -1.
Feb 13 14:30:11 2017    System Log    Message    daemon.err wbm_run: possible DNS Rebinding attack detected! (from ip 0x192.168.1.4)

Hors ligne

#5 13-02-2017 16:14:29

CrazyCat
Chat
Inscription : 14-01-2016
Messages : 420

Re : Erreur 403 serveur

Oui, je ne suis pas étonné: la box voit une ip interne qui tente d'accéder par l'extérieur et peut "imaginer" que c'est une tentative pour quelqu'un d'extérieur de faire croire qu'il est à l'intérieur.

Hors ligne

#6 13-02-2017 16:38:34

czeuw
Membre
Inscription : 13-02-2017
Messages : 4

Re : Erreur 403 serveur

Bon ben on va dire que c'est cuit ! smile

Hors ligne

Pied de page des forums