RaspFR :: Forum

Forum de la communauté francophone de Raspberry PI.

Vous n'êtes pas identifié(e).

Annonce

Canal irc: #raspfr sur zeolia.net

#1 05-04-2016 11:08:55

aguirab
Membre
Lieu : NICE
Inscription : 26-03-2016
Messages : 131

[résolu] pi n'a plus de mode graphique (erreur enable boot to desktop)

bon jour,

j'ai un pi B+ avec dessus (sur gpio) un écran tft tactile 3,5"
tout marchait bien

mais suite à un nettoyage selon les conseils de :  http://www.magdiblog.fr/divers/supprime … -raspbian/
- désinstall des paquets superflus
- désinstall des paquets et dépendances inutilisés (apt-get autoremove -y)
- suppression du cache des fichiers inutiles
puis
apt-get upgrade
rpi-update

voilà que le pi refuse de booter en mode graphique
il ne boote qu'en mode console

ne peux pas dans raspi-config selectionner le mode boot desktop
le message d'erreur est : "there was an error running option 3 Enable Boot to Desktop/Scratch

bon voilà que je vois que dans le dossier /usr/share/X11
le dossier "xorg.conf.d" a disparu
je pense que je l'ai supprimé

donc je vais essayer de réparer
?

Dernière modification par aguirab (15-02-2017 20:57:50)

Hors ligne

#2 05-04-2016 12:16:18

Claudius
Membre
Lieu : 78 - Yvelines
Inscription : 06-05-2015
Messages : 160
Site Web

Re : [résolu] pi n'a plus de mode graphique (erreur enable boot to desktop)

Bonjour,

Désolé pour toi, je te conseille de parcourir la toile au moyen d'une recherche Google (en autre ;-) avec cette erreur:
There was an error running option 3 Enable Boot to Desktop/Scratch

Edit: As-tu fais une sauvegarde de la SD avant cette manipulation qui, par bon sens, peut se révéler "destructrice" ?

Dernière modification par Claudius (05-04-2016 12:20:54)

Hors ligne

#3 05-04-2016 15:01:25

aguirab
Membre
Lieu : NICE
Inscription : 26-03-2016
Messages : 131

Re : [résolu] pi n'a plus de mode graphique (erreur enable boot to desktop)

bonjour claudius
j'ai rien sur la SD que l'OS et ce que j'ai installé
càd
tightvncserver
xrdp (Remote Desktop Protocol Server)
aceweasel
vsftpd
LCD-show
VLC
motion (installé puis désinstallé)
RPi_Cam_Web_Interface
speedtest
LCD-show
mjpg-streamer
dropbox
sysstat
j'ai l'impression que c'est un peu hétéroclite tout ça

Dernière modification par aguirab (05-04-2016 15:18:02)

Hors ligne

#4 05-04-2016 16:30:16

Claudius
Membre
Lieu : 78 - Yvelines
Inscription : 06-05-2015
Messages : 160
Site Web

Re : [résolu] pi n'a plus de mode graphique (erreur enable boot to desktop)

aguirab a écrit :

j'ai rien sur la SD que l'OS et ce que j'ai installé
càd
tightvncserver
xrdp (Remote Desktop Protocol Server)
aceweasel
...
mjpg-streamer
dropbox
sysstat

j'ai l'impression que c'est un peu hétéroclite tout ça

Comme tu sembles ne pas avoir fait de sauvegarde, je te propose de repartir d'une feuille blanche ou presque et de t'inspirer de ce qui existe...
Cf. Transformez votre Raspberry Pi en client léger avec rdesktop

Maintenant, après réflexion, je pense que le RPi-B+ n'est pas dimensionné pour ce que tu souhaites, faudrait penser à monter en puissance avec un B2 voire un B3 ;-)

A suivre...

Dernière modification par Claudius (05-04-2016 16:32:05)

Hors ligne

#5 05-04-2016 19:43:38

chris57100
Chris
Lieu : Thionville
Inscription : 23-06-2013
Messages : 1 405
Site Web

Re : [résolu] pi n'a plus de mode graphique (erreur enable boot to desktop)

Le problème de l'article c'est qu'il ne dit ce qu'il supprime pour un "novice". Or en regardant les paquets supprimés, il y a toute la partie graphique et gestionnaire de bureau (lxde et non KDE comme écrit)
Essaye l'installation de X11 et lxde (il faut trouver le nom exact du paquet). En mode console réinstalle tout. Rentre la commande :

[== Indéfini ==]
apt-get install -y desktop-base x11-common midori omxplayer scratch dillo xpdf galculator netsurf-common netsurf-gtk lxde-common lxde-icon-theme hicolor-icon-theme libpoppler19 ed lxsession lxappearance lxpolkit lxrandr lxsession-edit lxshortcut lxtask lxterminal xauth debian-reference-common fontconfig fontconfig-config fonts-freefont-ttf wolfram-engine dbus-x11 desktop-file-utils libxmuu1 libraspberrypi-doc

Pour le code erreur, sous Unix tu peux démarrer une "console" dans différent mode et le 3 de mémoire est lié au mode graphique que tu as désinstallé.


Raspberry Pi Home Server : http://www.pihomeserver.fr
Tutorials and tips : Samba, Airplay, CUPS, Time machine, MPD+Rompr, Nginx, Owncloud, rTorrent+ruTorrent, Wordpress, Joomla, Subsonic, VNC, etc.
Electronic : weather station, Arduino, etc.

Hors ligne

#6 05-04-2016 21:21:34

aguirab
Membre
Lieu : NICE
Inscription : 26-03-2016
Messages : 131

Re : [résolu] pi n'a plus de mode graphique (erreur enable boot to desktop)

oui j'ai :
Xsession: unable to start X session --- no "/home/pi/.xsession" file, no "/home/pi/.Xsession" file, no session managers, no window managers, and no terminal emulators found; aborting.
je vais donc essayer comme tu dis

Hors ligne

#7 05-04-2016 22:47:44

aguirab
Membre
Lieu : NICE
Inscription : 26-03-2016
Messages : 131

Re : [résolu] pi n'a plus de mode graphique (erreur enable boot to desktop)

oups
j'ai bien une session graphique
le résultat est surprenant mais beau
je pense qu'il y a de tout
lxde debian etc...
c'est le souk je suis paumé
et mon écran tft 3,5" ne fonctionne plus, le driver est parti je ne sais où
bref je sors la SD et je repars à zéro
-----
merci de votre compréhension

Hors ligne

#8 13-04-2016 21:58:56

aguirab
Membre
Lieu : NICE
Inscription : 26-03-2016
Messages : 131

Re : [résolu] pi n'a plus de mode graphique (erreur enable boot to desktop)

bonjour,
j'ai abandonné la recherche de réparation
et installé un wheezy (version 7) avec driver pour écran LCD tft 3,5" intégré
"PITFT35_12MHz.img"
tout va bien de ce côté
seulement dans mes expériences d'installation
je me suis aperçu du fait que si je fais
apt-get update
apt-get upgrade
celà détruit le driver (plantage au boot l'écran ne fonctionne plus)
alors j'ai trouvé sur un site
faire avant
apt-mark hold raspberrypi-bootloader
et le driver est conservé
quelqu'un pourrait il me dire pourquoi et si je fais bien ?
merci

Hors ligne

#9 13-04-2016 22:01:48

chris57100
Chris
Lieu : Thionville
Inscription : 23-06-2013
Messages : 1 405
Site Web

Re : [résolu] pi n'a plus de mode graphique (erreur enable boot to desktop)

Parce que pour l'écran le fabriquant a fait un bootloader spécifique en écrasant la version officielle. Du coup si tu fais une mise à jour c'est écrasé. apt-mark signe que le paquet ne doit pas être modifié ou mis à jour, ca permet de le conserver et donc avec ton driver. Pas le choix si tu veux garder ton driver ...


Raspberry Pi Home Server : http://www.pihomeserver.fr
Tutorials and tips : Samba, Airplay, CUPS, Time machine, MPD+Rompr, Nginx, Owncloud, rTorrent+ruTorrent, Wordpress, Joomla, Subsonic, VNC, etc.
Electronic : weather station, Arduino, etc.

Hors ligne

#10 14-04-2016 13:52:56

aguirab
Membre
Lieu : NICE
Inscription : 26-03-2016
Messages : 131

Re : [résolu] pi n'a plus de mode graphique (erreur enable boot to desktop)

bonjour,
ok
je suis donc prisonnier de ce bootloader
et je dois bien faire attention à chaque upgrade
merci

Hors ligne

#11 14-04-2016 20:35:52

chris57100
Chris
Lieu : Thionville
Inscription : 23-06-2013
Messages : 1 405
Site Web

Re : [résolu] pi n'a plus de mode graphique (erreur enable boot to desktop)

Je pense qu'une fois marqué il n'y a plus besoin de faire le marquage


Raspberry Pi Home Server : http://www.pihomeserver.fr
Tutorials and tips : Samba, Airplay, CUPS, Time machine, MPD+Rompr, Nginx, Owncloud, rTorrent+ruTorrent, Wordpress, Joomla, Subsonic, VNC, etc.
Electronic : weather station, Arduino, etc.

Hors ligne

#12 14-04-2016 23:25:11

aguirab
Membre
Lieu : NICE
Inscription : 26-03-2016
Messages : 131

Re : [résolu] pi n'a plus de mode graphique (erreur enable boot to desktop)

bonjour,
je vais rechercher pour voir si c'est bien le cas

Hors ligne

Pied de page des forums